System degraded: app admin temporarily unavailable
Incident Report for Judge.me
Resolved
Admin dashboards on Judge.me were temporarily unavailable for some users. Our system performance was degraded due to high amount of orders coming from Black Friday that we had to process to send review request emails.

Update: This has been resolved and all apps are live again.
Posted Dec 10, 2021 - 16:00 UTC