AWS has resolved the underlying issue causing service disruptions. Our affected systems — including the homepage, support chat, and impacted vendor services — have recovered and are now operating normally. Review widgets and review creation were unaffected throughout the incident. We will continue to monitor system stability, but no further impact is expected.
Posted Oct 20, 2025 - 11:28 UTC
Monitoring
We are currently experiencing an ongoing AWS outage that is affecting several parts of our system, including our homepage and support chat. Some of our third-party service vendors are also impacted, which may cause additional disruptions or slower performance. We are monitoring the situation closely and will provide updates as AWS and our vendors work toward a resolution.
Our review widgets remain functional, and new reviews are being created and displayed as normal.
Posted Oct 20, 2025 - 08:14 UTC
Investigating
We’re currently experiencing an issue with AWS services that may impact parts of our system. Our support chat is directly affected and may be temporarily unavailable or slow to respond. We’re monitoring the situation closely and will provide updates as soon as AWS resolves the issue.
Posted Oct 20, 2025 - 08:00 UTC
This incident affected: Judge.me Product Reviews - Admin and AliExpress Review Importer.