Judge.me is not loading for some users
Incident Report for Judge.me
Resolved
All Judge.me pages and widgets are loading normally now. Thanks for being patient with us!
Posted Feb 24, 2022 - 17:25 UTC
Update
We believe the outage is due to connectivity issues with our upstream provider. We are continuing to investigate.
Posted Feb 24, 2022 - 17:23 UTC
Investigating
We’re looking into the cause and will provide more information as soon as it's available.
Posted Feb 24, 2022 - 17:03 UTC
This incident affected: Judge.me Product Reviews - Admin, Judge.me Product Reviews - Storefront widgets, and AliExpress Review Importer.